RU
22.10.2018

Vulnerabilităţi în routere Linksys E Series

Talos dezvăluie trei vulnerabilități la nivelul sistemului de operare de la distanță, care afectează routerele Linksys E Series.
Grupul Talos al Cisco a cercetat anumite vulnerabilități din seria E și a publicat rezultatele. Pentru a exploata aceste vulnerabilități, un atacator ar trebui să trimită o cerere HTTP special creată, rău intenționată, pentru a schimba configurația dispozitivului. Dacă este reușit, impactul rezultat ar putea fi executarea unui cod arbitrar pe dispozitivul vulnerabil.

Detaliile de configurare ale sistemului trebuie să treacă printr-o restartare a dispozitivului deoarece singurul directoriu care poate fi scris pe dispozitiv /tmp este șters în timpul inițializării sistemului, NVRAM este locul în care sunt stocate datele.
După restartare, codul de startare trage datele brute din NVRAM și îl plasează într-un buffer care va fi apoi executat.
Comenzile injectate în NVRAM de către un atacator pot fi executate în timpul acestui ciclu.

Linksys a publicat deja un patch, care este disponibil pentru descărcare care rezolvă aceste probleme.
Patch-ul e disponibil pe link-ul de mai jos.
http://downloads.linksys.com/downloads/firmware/FW_E2500_3.0.05.002_20180914.bin.

Orange Moldova CERT recomandă menținerea aplicațiilor și a sistemelor de operare la nivelul actualizat la zi.


Buletin informativ

Primeşte ştiri de top direct pe email