RU
19.10.2018

Vulnerabilitate de autentificare în libssh

Vulnerabilitatea afectează toate sistemele care utilizează versiunea libssh mai mare de 0,6.
Libssh este o bibliotecă C multiplatformă care implementează protocolul SSHv2 și SSHv1 pe partea clientului și a serverului. Vulnerabilitatea se referă la procesul de autentificare.
Aceasta permite unui atacator de la distanță, prezentând serverul cu un mesaj "SSH2_MSG_USERAUTH_SUCCESS" în loc de mesajul "SSH2_MSG_USERAUTH_REQUEST" cu scopul de a iniția autentificarea.
Aceasta înseamnă că o persoană răufăcătoare poate ocoli mecanismul de autentificare pe un sistem vulnerabil.
Acest lucru permite unei persoane rău intenționate să ocolească mecanismul de autentificare și un atacator ar putea se autentifica fără acreditări.
Un exploit deja a fost publicat pe Internet pentru această vulnerabilitate, ne putem aștepta ca acesta să fie utilizat în mare măsură în zilele următoare.
Libssh a publicat deja versiunea libssh 0.8.4 și libssh 0.7.6 pentru a adresa această problemă.
Orange Moldova CERT recomandă să aplicaţi patch-uri cât mai curând posibil.

Buletin informativ

Primeşte ştiri de top direct pe email